Recommand · October 22, 2021 0

Heroku error: No matching distribution found for conda-verify (from -r /tmp/build_a8d7420d/requirements.txt

I deployed many heroku app before without any problem.
Now I’m facing with a build error I cannot go off.
I created a brand new app, following the heroku suggested steps.
The app has been developed with latest pycharm community version.
The app has a requirements.txt file created by pip freeze, without any version specification due to similar errors with the standard version.
during building I get some blocking errors as following.
Can somebody give me a suggestion?

D:\Dropbox\Applicazioni\shibot>git push heroku master
Enumerating objects: 4168, done.
Counting objects: 100% (4168/4168), done.
Delta compression using up to 4 threads
Compressing objects: 100% (4108/4108), done.
Writing objects: 100% (4168/4168), 12.57 MiB | 3.12 MiB/s, done.
Total 4168 (delta 728), reused 0 (delta 0)
remote: Compressing source files... done.
remote: Building source:
remote:
remote: -----> Building on the Heroku-20 stack
remote: -----> Determining which buildpack to use for this app
remote: -----> Python app detected
remote: -----> No Python version was specified. Using the buildpack default: python-3.9.7
remote:        To use a different version, see: https://devcenter.heroku.com/articles/python-runtimes
remote: -----> Installing python-3.9.7
remote: -----> Installing pip 20.2.4, setuptools 57.5.0 and wheel 0.37.0
remote: -----> Installing SQLite3
remote: -----> Installing requirements with pip
remote:        Collecting bdateutil
remote:          Downloading bdateutil-0.1.tar.gz (24 kB)
remote:        Collecting bitarray
remote:          Downloading bitarray-2.3.4.tar.gz (88 kB)
remote:        Collecting bkcharts
remote:          Downloading bkcharts-0.2.tar.gz (97 kB)
remote:        Collecting bokeh
remote:          Downloading bokeh-2.4.1-py3-none-any.whl (18.5 MB)
remote:        Collecting boto
remote:          Downloading boto-2.49.0-py2.py3-none-any.whl (1.4 MB)
remote:        Collecting bottleneck
remote:          Downloading Bottleneck-1.3.2.tar.gz (88 kB)
remote:          Installing build dependencies: started
remote:          Installing build dependencies: still running...
remote:          Installing build dependencies: still running...
remote:          Installing build dependencies: still running...
remote:          Installing build dependencies: still running...
remote:          Installing build dependencies: finished with status 'done'
remote:          Getting requirements to build wheel: started
remote:          Getting requirements to build wheel: finished with status 'done'
remote:            Preparing wheel metadata: started
remote:            Preparing wheel metadata: finished with status 'done'
remote:        Collecting brotlipy
remote:          Downloading brotlipy-0.7.0-cp39-cp39-manylinux1_x86_64.whl (1.1 MB)
remote:        Collecting conda-build
remote:          Downloading conda_build-2.1.5-py3-none-any.whl (235 kB)
remote:        ERROR: Could not find a version that satisfies the requirement conda-verify (from -r /tmp/build_a8d7420d/requirements.txt (line 9)) (from versions: none)
remote:        ERROR: No matching distribution found for conda-verify (from -r /tmp/build_a8d7420d/requirements.txt (line 9))
remote:  !     Push rejected, failed to compile Python app.
remote:
remote:  !     Push failed
remote: Verifying deploy...
remote:
remote: !       Push rejected to shibuchou.
remote:
To https://git.heroku.com/shibuchou.git
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https://git.heroku.com/shibuchou.git'